Our team managed to fix the issue, The issue affected only Shopify and Magento2 platforms.
The solution for Magento2 should be implemented by your developers with the following guidelines :
- Please update our app to its latest version in the Magento marketplace OR -Download the files from github (https://github.com/YotpoLtd/magento2-module-yotpo-loyalty) and manually place them under app/code/Yotpo/Loyalty, and then run the other CLI commands as always. *If you previously installed with composer or via the marketplace, they should remove that first. OR just use composer normally. Composer will just get the files from Github and put that under the vendor dir
For Shopify merchants, we pushed a fix that should replace the URL with a new one.
If you still encounter any issue like this, please reach out to our support so we can assist to fix it manually as well.
*A workaround for Shopify merchants that still have the issue:
- For merchants that can access their liquid file, go to theme.liquid file and change the URL from cdn.swellrewards.com to cdn-loyalty.yotpo.com
Thanks for your understanding and collaboration.
Posted Jan 05, 2023 - 11:04 IST
Update
We are continuing to monitor for any further issues.
Posted Jan 05, 2023 - 10:51 IST
Monitoring
Our team determined this is only affecting Shopify and Magento2.
Please find below a workaround from shopify: - For merchants that can access their liquid file, go to theme.liquid file and change the URL from cdn.swellrewards.com to cdn-loyalty.yotpo.com
Please find below a fix for Magento2: - Please update our app to its latest version in the magento marketplace OR -Download the files from github (https://github.com/YotpoLtd/magento2-module-yotpo-loyalty) and manually place them under app/code/Yotpo/Loyalty, and then run the other CLI commands as always. *If you previously installed with composer or via the marketplace, they should remove that first. OR just use composer normally. Composer will just get the files from Github and put that under the vendor dir
Posted Jan 04, 2023 - 22:48 IST
Identified
Overall Description of the issue and Affected Services:
There is currently an issue with our certificate for cdn.swellrewards.com not working as intended.
Start Time: January 4, 2023 04:00 PM UTC
Business Impact: - For merchants using this link in their implementation, it could cause some elements to not load on-site for customers
We apologize for the inconvenience caused. Our R&D team is already working on fixing this issue.
If you have any further questions or concerns, please feel free to reach out to us by live chat or by submitting a support case.